3-3-3 ウィンドウの表示状態を変更する

帳票デザインの設計時によく使用される設定ウィンドウは、タブ状態、ドッキング状態、フローティング状態の3つの表示状態に切り替えることができます。

表示の切り替えが可能なウィンドウは、次の6つです。

  • パレットカラー設定]ウィンドウ

  •  グリッドの設定]ウィンドウ

  •  編集アイテムの選択]ウィンドウ

  •  プロパティエディター

  •  ナビゲーター

  •  クエリーデザイナー

インストール直後の初期状態では、次のように表示されます。


初期状態でのウィンドウのドッキング状態(左)とタブ状態(右)

表示状態を切り替える

これらのウィンドウの表示状態を切り替えるには、各ウィンドウの上部に表示されるボタンを利用します。それぞれの状態からの表示切り替えは、次のとおりです。


ウィンドウの表示状態の切り替え

をクリックするとウィンドウが閉じます。

表示状態の切り替えは、タイトルバー上で右クリックしたときに表示されるメニューからもできます。ただし、表示状態によっては、選択できないメニュー項目もあります。


タブ状態でのメニュー(左)と、ドッキング状態/フローティング状態でのメニュー(右)

各項目の内容は次のとおりです。

項目
説明

閉じる

 

ウィンドウを閉じます

非表示

 

ウィンドウを閉じてタブに戻します

フローティング

 

ウィンドウをフローティング状態に切り替えます

自動的に隠す

 

ウィンドウをタブ状態に切り替えます

最大化

 

ウィンドウを最大化して表示します

ドッキング可能

 

他のウィンドウとドッキングできるようにします。チェックを外すと、ウィンドウはタブ表示できなくなり、フローティング状態になります

タブ状態(自動非表示)からの切り替え

タブ状態のウィンドウを表示させるには、タブの上にマウスカーソルを重ねます。

 
タブの上にマウスカーソルを重ねると、ウィンドウが表示される

表示されたウィンドウの範囲からマウスカーソルを離すか、をクリックすると、ウィンドウは閉じ、タブ状態に戻ります。ウィンドウが開いた状態で をクリックすると、ドッキング表示に切り替わります。

ドッキング状態からの切り替え

ドッキング状態では、SVFX-Designerウィンドウの上下左右のいずれかの一辺に接してウィンドウが表示されます。


SVFX-Designerウィンドウ左側にドッキング表示されたウィンドウ

ウィンドウ上部にある をクリックすると、フローティング状態に切り替わります。をクリックすると、タブ状態に切り替わります。

フローティング状態からの切り替え

フローティング状態のウィンドウは、Form Designerのウィンドウから独立して表示されます。


フローティング状態のウィンドウ

ウィンドウ上部にある をクリックすると、ドッキング状態に切り替わります。

複数ウィンドウのドッキングと分離

ウィンドウをドッキング先のウィンドウにドラッグして重ねると、複数のウィンドウを1つのウィンドウにまとめることができます。初期状態では、ウィンドウ右端にある[パレットカラー設定]、[グリッドの設定]、[編集アイテムの選択]が1つにまとめられています。
複数のウィンドウを1つにまとめると、ドッキング状態またはフローティング状態のときに、それぞれのウィンドウのタイトルが表示しているウィンドウ下部にタブとして表示されます。


フローティング状態のウィンドウ下部にタブとして表示されたウィンドウタイトル

参考

ドッキングを解除する場合は、ウィンドウ下部のタブをドラッグして、元のウィンドウの領域外まで移動させます。

 

ウィンドウの表示サイズを変更する

Form Designerの各ウィンドウの表示サイズは、そのフレーム部分をドラッグすることにより変更できます。


ウィンドウサイズの変更

表示/非表示の切り替えをクリックするなどしていったん閉じた各ウィンドウは、次の操作で再表示できます。

閉じたウィンドウの名前 再表示の操作

パレットカラー設定

設定]-[パレットカラー設定

グリッドの設定

補助]-[グリッドの設定

編集アイテムの選択

補助]-[編集アイテムの選択

プロパティエディター

表示]-[プロパティウィンドウ

ナビゲーター

表示]-[ナビゲーター

クエリーデザイナー

ツール]-[クエリーデザイナー

参考
  • ナビゲーター]に表示されるナビゲーションツリーの表示/非表示の切り替えは、[ 設定]-[動作設定]-[ 表示]から行うことができます。詳細は、「3-2 動作設定」の「3-2-2 表示」を参照してください。

  • ツールバー領域の右クリックで表示されるメニューから[ レイアウトのリセット]を選択すると、それまでのレイアウト情報はリセットされ、Form Designerがインストールされた直後の状態になります。