3-4-8 画像ファイルを帳票イメージとして読み込む

帳票デザインの画像ファイルがある場合は、イメージとして読み込んで、下絵として利用できます。モノクロBMP、8/16/24ビット色カラーBMP、JPEG、GIF、PNG、TIFF(非圧縮、G3圧縮、G4圧縮)形式の画像ファイルを400dpiで読み込んだときは、下絵から罫線や文字を抽出して、アイテムとして配置することが可能です。


画像ファイルを下絵として配置

制限事項
  • TIFF(非圧縮、G3圧縮、G4圧縮以外)は下絵にはできますが、罫線、文字抽出はできません。
  • アニメーションGIF、透過GIF、透過PNGの読み込みには対応していません。

帳票イメージは、次の手順で読み込みます。

  1. 新規ファイルを作成する

    ファイル]-[新規フォーム]を選び、新しいフォームを作成します。ツールバーの[新規 (SVF Form)]ボタンのクリックでも、新規ファイルを作成できます。

  2. 用紙サイズと方向を指定する

    読み込むファイルに合わせて、[プロパティエディター]で[用紙サイズ]および[用紙方向]を指定します。

  3. 画像ファイルを選択する

    表示]-[帳票のイメージ読み込み]を選択します。
    開く]ダイアログが表示されます。
    画像ファイルの解像度を100dpi、または400dpiから選択します。


    開く]ダイアログ

    参考
    • 開く]ダイアログでの[解像度]の初期値は、[設定]-[動作設定]-[イメージ読み込み]の[解像度]で指定しておくことができます。

    • PREVIEW]ボタンをクリックすると、選択した画像ファイルのイメージが別ウィンドウで表示されます。


      別ウィンドウで表示されたイメージのプレビュー

  4. ファイルを開く

    ファイルを選択して[開く]ボタンをクリックします。
    帳票のイメージが下絵として読み込まれます。


    帳票のイメージが下絵として読み込まれる

帳票イメージから罫線を自動作成する

読み込む帳票イメージの線分を認識し、罫線を自動作成できます。

  1. ツールを選択する

    アイテム]-[帳票イメージから罫線を読み込む]を選択するか、[帳票イメージから罫線を読み込む]ボタンをクリックします。
    マウスカーソルの形状がに変わります。

  2. 罫線の範囲を囲む

    フォームウィンドウで、帳票イメージの読み込みたい範囲を、マウスドラッグで矩形を描くように囲みます。
    囲んだ範囲内の罫線が抽出され、直線が作成されます。

    制限事項
    • 斜め線は認識できません。
    • 左上の角が丸い表は認識できない場合があります。
    • パステル系の明るい色(黄色、黄緑色、水色など)の罫線は、認識されない場合があります。
    • 罫線の色は区別されず、黒色として認識されます。
    • 帳票イメージ上に画像やバーコードがあると、矩形が作成される場合があります。
    • 伸縮や回転したイメージは認識できません。

直線で描画した矩形を1つの図形にする

帳票イメージから罫線を自動作成した場合は、罫線は矩形としてではなく、直線として作成されます。直線の四辺を合成して1つの矩形に変換できます。


直線の四辺を合成して矩形に変換

制限事項

矩形に変換する場合は、四辺すべての直線が垂直、または水平である必要があります。斜線が1つでも含まれていると変換できません。

矩形への変換は、次の手順で行います。

  1. 矩形にする罫線を選択する

    Shiftキーを押しながら、各辺となる4つの直線を選択後、[編集]-[罫線を矩形に変換]を選択するか、[罫線を矩形に変換]ボタンをクリックします。
    矩形の設定]ダイアログが表示されます。


    矩形の設定]ダイアログ

  2. プロパティを設定する

    プロパティの各項目を設定します。
    矩形のプロパティについては、「3-8-4 基本図形を描く」の「矩形」を参照してください。

  3. 矩形に変換される

    OK]ボタンをクリックすると、選択した直線が矩形に変換されます。

帳票イメージから固定文字を自動作成する

OCR機能を利用すると、取り込んだ帳票イメージの文字を認識し、固定文字として自動作成できます。
帳票イメージから固定文字を作成するには、次の手順で操作します。

参考

設定]-[動作設定]-[範囲/OCR 設定]で「読み込みモード」、「文字の調整」、「固定文字、直線の設定」の設定を変更できます。

  1. OCRを選択

    アイテム]-[帳票イメージから文字を読み込む]を選択するか、[帳票イメージから文字を読み込む]ボタンをクリックします。
    マウスカーソルの形状がに変わります。

  2. 単語を範囲選択する

    フォームウィンドウで、帳票イメージの読み込みたい範囲を、マウスドラッグで矩形を描くように囲みます。
    囲んだ範囲内の文字が抽出され、固定文字が作成されます。

制限事項
  • パステル系の明るい色(黄色、黄緑色、水色など)の文字は、認識されない場合があります。
  • OCR抽出では、基本的に全角半角は区別して取り込まれますが、帳票イメージの状態により、正しく区別されない場合があります。
  • 伸縮や回転したイメージは認識できません。
参考

個別の固定文字として読み込まれた固定文字を結合することができます。手順は、「3-5-12 アイテムを異なる種類に変換する」の「固定文字を結合する」を参照してください。

帳票のイメージを高品質表示する

読み込んだ帳票イメージを高品質表示にすると、よりクリアな帳票イメージを表示できます。
高品質表示にするには、[表示]-[帳票のイメージの高品質表示]を選択し、チェックが付いた状態にします。
再度同じメニューを選択すると、高品質表示から通常の表示に戻すことができます。


通常の表示(上)と高品質表示(下)

帳票イメージの表示/非表示を切り替える

下絵の帳票イメージの表示/非表示を切り替えることができます。
表示/非表示を切り替えるには、[表示]-[帳票のイメージ表示]または[帳票のイメージ非表示]を選択します。選択するたびに、[帳票のイメージ非表示]、[帳票のイメージ表示]とメニュー表示が変わります。
Ctrl + Bキーでも、表示/非表示を切り替えることができます。

帳票のイメージの位置を調整する

アイテム、図形の配置位置に合わせて、帳票イメージの位置を調整できます。
帳票イメージの位置の調整には、帳票イメージ自体を選択する方法と、帳票イメージのプロパティで位置情報を数値で設定する方法があります。
帳票イメージの位置を調整するには、まず帳票イメージが選択された状態にしておきます。

帳票イメージを選択する

帳票イメージを選択するには、[帳票のイメージ選択]ボタンをクリックするか、[表示]-[帳票のイメージ選択]を選択します。帳票イメージが選択された状態になると、マウスカーソルがに変わり、プロパティエディターに帳票イメージの設定内容が表示されます。
帳票イメージ以外の場所をクリックするか、Escキーを押すと、選択が解除されます。


帳票イメージが選択される

帳票イメージの位置を上下左右に移動する

帳票イメージを選択し、マウスでドラッグして目的の位置に移動します。キーボードの矢印キーを使用しても移動できます。

帳票イメージを拡大/縮小する

帳票イメージを選択すると、帳票イメージの周りに四角いハンドルが表示されます。
ハンドルを動かすことによって、帳票イメージを拡大/縮小できます。


ハンドルをドラッグして帳票イメージを拡大/縮小する

角のハンドルをドラッグすると、縦横同時に拡大/縮小されます。縦、横の辺のハンドルをドラッグすると、縦、または横方向に拡大/縮小されます。
Ctrlキーを押しながらドラッグした場合は、図の中央点を基点に拡大/縮小されます。
また、Shiftキーを押しながらドラッグした場合は、左辺中央を基点に等倍に拡大/縮小されます。

帳票イメージを回転する

帳票イメージを選択すると、帳票イメージの右横に丸いハンドルが表示されます。
ハンドルにマウスカーソルを合わせてアイコンと表示されたら、回転する方向にドラッグします。


帳票イメージが回転される

帳票イメージのプロパティを設定する

帳票イメージの位置は、[プロパティエディター]でも設定できます。
プロパティエディターでは、位置情報のほかに、ファイル名の選択やページごとの表示を設定できます。

  1. 帳票イメージを選択する

    帳票のイメージ選択]ボタンをクリックするか、[表示]-[帳票のイメージ選択]を選択し、帳票イメージを選択します。
    プロパティエディターに帳票イメージの設定項目が表示されます。

  2. プロパティを設定する

    各項目を設定します。


    帳票イメージのプロパティ

    項目
    説明

    名前

    帳票イメージの名称を入力します。

    ファイル名

    表示する帳票イメージのファイルが指定されています。ファイルを変更する場合は、[ファイル名]欄の右端の[...]をクリックして表示される[開く]ダイアログから画像ファイルを選択します。

    始点X(dot)
    イメージ左上隅のX座標をドット単位で設定します。

    始点Y(dot)

    イメージ左上隅のY座標をドット単位で設定します。

    終点X(dot)

    イメージ右下隅のX座標をドット単位で設定します。

    終点Y(dot)

    イメージ右下隅のY座標をドット単位で設定します。

    回転角度

    水平横軸を「0」として回転角度を指定します。設定できる値の範囲は359から-359で、+値の場合は反時計回りに、-値の場合は時計回りに帳票イメージが回転します。