SVF/SPA:Oracle JDKのリリース・モデル変更に伴うサポート方針について

製品ブランド:

SVF

SPA

公開日時:

2018/10/22 09:00

更新日時:

2021/06/30 09:00

記事番号:

000015839

対象製品

製品ブランド 対象製品 バージョン 備考

SVF 

SVFX-Designer Ver.8.2以降  
SVF Web Designer Ver.9.2以降  
SVF for PDF Ver.8.2以降 オプション製品を含む
SVF for Java Print  Ver.8.2以降 オプション製品を含む
SVF for PDF Client Edition Ver.9.2以降  
Report Director Enterprise Ver.8.2以降 オプション製品を含む
RDE Limited Ver.9.2  
RDE Utility Developer's Kit Ver.8.2以降  
Universal Connect/X Ver.8.2以降 UCXSingle Java版を含む
SVF for TIFF図面 Ver.8.2以降  
SVF for Oracle E-Business Suite Ver.8.2以降  
SVF Connect for Java API Ver.8.1以降  
SVF EA Connect Ver.9.2、Ver.9.3  
SVF Connect for IXOS Ver.1.1c~Ver.1.1d
Ver.9.2
 
SVF StraForm Designer(旧:StraForm デザイナ) Ver.1.6c~Ver.1.7  
SVF StraForm Ver.1.7  
SVF StraForm Volc(旧:StraForm Volc) Ver.1.0
Ver.1.7
 
SPA SPA Connect for Java API Ver.9.3以降  
SPA ETL Option Ver.10.0、Ver.10.2  

 

内容

オラクル社から発表されているとおり、2018年9月にリリースされたJava11以降、Oracle JDKは有償となり、LTS(Long Term Support)モデルへ移行します。
参考:JDKの新しいリリース・モデルおよび提供ライセンスについて
http://www.oracle.com/technetwork/jp/articles/java/ja-topics/jdk-release-model-4487660-ja.html

上記のオラクル社の発表を受け、「Oracle/OpenJDK 11以降に対応するSVF/SPA製品」、および、一部を除いた2019年に新たにリリースする製品(バージョン)の対応方針は以下をご参照ください。


本ページは随時、更新いたします。 

 

Amazon Corretto8、JDK 11以降に対応するSVF/SPA製品

※以下に記載されていない製品(バージョン)はAmazon Corretto 8 、および、JDK11以降の対応予定はありません。製品のバージョンアップをご検討ください。

製品ブランド 対象製品 バージョン 対応時期 対応方法

SVF 

SVF Web Designer Ver.10

Oracle JDK11、Oracle OpenJDKに対応してます。
また、Ver.10.1よりAmazon Corretto 8に対応してます。

Javaの対応状況、および、利用時の条件・制限事項は以下を参照ください。
 Java VM のバージョンにおける弊社製品の動作状況について

お客様にてJavaの入れ替えをお願いします。
 SVF製品:JREが同梱されている弊社製品及び入れ替え手順
SVFX-Designer
SVF for PDF Ver.9.2
Ver.10
Oracle JDK11、Oracle OpenJDKに対応してます。
また、Ver.9.2 Service Pack9、および、Ver.10.1よりWindows環境を対象にAmazon Corretto 8に対応してます。

Javaの対応状況、および、利用時の条件・制限事項は以下を参照ください。
 Java VM のバージョンにおける弊社製品の動作状況について
 
SVF for Java Print 
SVF for PDF Client Edition
Report Director Enterprise
RDE Limited
RDE Utility Developer's Kit
Universal Connect/X
SVF for TIFF図面
SVF for Oracle E-Business Suite
SVF Connect for Java API
SVF EA Connect 未定 2021年夏頃にベンダーがサポートしているJDKへ入れ替えた次期バージョンをリリース予定です。

なお、Ver.9.2に同梱しているJavaはOracle社の公式アップデート終了後も通常保守サービスと同様に、弊社にて原因の切り分けを実施し、製品に起因する問題の場合には、パッチを提供いたしますので安心してご利用ください。
SVF Connect for IXOS 9.2
Oracle Java11、Oracle OpenJDK13に対応しています。

お客様にてJavaの入れ替えをお願いします。
SVF製品:JREが同梱されている弊社製品及び入れ替え手順

SVF StraForm サーバー Ver.1.7
Ver.1.7 Service Pack4の適用を前提としAdoptOpenJDK11(HotSpot)に対応しています。
SVF StraForm Designer
SVF StraForm Volc API Ver.1.7 Service Pack4の適用を前提とし、AdoptOpenJDK11, RedHatOpenJDK11、Oracle OpenJDKに対応しています。
Javaを利用できるOSの組み合わせ、制限事項は以下を参照ください。
SVF StraForm製品の動作状況について
SVF StraForm Volc WebサービスAPI
SPA SPA Connect for Java API Ver.10 Oracle JDK11、RedHatOpenJDK11、AdoptOpenJDK11、 Oracle OpenJDKに対応しています。
Javaを利用できるOSの組み合わせ、制限事項は以下を参照ください。
 Java VM のバージョンにおける弊社製品の動作状況について
※SPA Ver.10.0以降のマイナーバージョンは、SPA Ver.9.3以前のService Packと同様に、サポートサイトからダウンロードでき、製品をアインインストールすることなくモジュール適用によりアップデートが可能です。
詳細は、以下をご参照ください。
https://cs.wingarc.com/ja/supportpolicy/000015990
お客様にてJava11へ入れ替えてください。
SPA ETL Option 未定 2021年夏頃にベンダーがサポートしているJDKへ入れ替えた次期バージョンをリリース予定です。

なお、Ver.10.0、Ve.10.2に同梱しているJavaはOracle社の公式アップデート終了後も通常保守サービスと同様に、弊社にて原因の切り分けを実施し、製品に起因する問題の場合には、パッチを提供いたしますので安心してご利用ください。

 

Oracle JDKに加え、オラクル公式OpenJDK(以下、OpenJDK)を動作環境とする対象製品について
OpenJDKにLTSが提供された場合にはLTS指定されたフィーチャーバージョンを、LTSが提供されない場合にはOpenJDKがメジャーバージョンアップする毎(リリースサイクル:6ヶ月)に最新のService Packを適用いただくことを前提として対応を表明します。
なお、Javaに起因する問題の場合、弊社の「SVF製品におけるJavaに関するサポートポリシー」に基づき、製造元への調査の依頼等、切り分けに必要なご協力やJavaのバージョンアップをお願いする場合があります。あらかじめご了承ください。
  

     

<OpenJDKにLTSが提供された場合の基本的なOracle Java/OpenJDKの対応の考え方>
例:OpenJDKにてLTS指定されたフィーチャーバージョンがOpenJDK11、OpenJDK17だった場合    

    15389-1    

 ※1. Oracle Java(LTS)の他に、OpenJDK(LTS)の最新フィーチャーバージョンの対応を表明します。
 

<OpenJDKにLTSが提供されない場合の基本的なOracle Java/OpenJDKの対応の考え方>  

    15389-2

※2. Oracle Java(LTS)の他に、該当製品の最新Service Packと最新のOpenJDKの組み合わせにて対応を表明します。 
※3. 該当製品のService PackがOpenJDKのリリースサイクルに合わせられない場合には、最新のService Packと最新のOpenJDKの組み合わせにて対応を表明します。

 

Amazon Corretto 8、JDK 11以降に対応しないSVF/SPA製品の扱いについて

製品に同梱のJavaをご利用の場合、Oracle Javaの公式アップデート終了後も引き続き製品をご利用いただくことが可能です。
また、弊社の「SVF・SPA製品におけるJavaに関するサポートポリシー」に基づき、該当製品の販売期間中、製品側の新たな問題に対して修正をさせていただきます。
ただし、弊社の調査の結果、弊社がJavaに起因する問題と判断した場合には、脆弱性を含めJavaのバージョンアップをお願いする場合があります。

 

2019年1月1日以降、新たにリリースする製品の扱いについて

2019年1月1日以降に新規リリースするSVF EA Connect、および、SVF StraFormを除くSVF製品 Ver.10.0より同梱するJREを無償のOpenJDK(11以降)に変更します。
なお、Java 11以降、32bit版は提供されなくなるため、SVF EA Connect、および、SVF StraFormを除くSVF製品はVer.9.2をもって32bitOSの対応を終了し、以降のバージョンでは64bitOSのみの対応とさせていただきます。
Ver.9.2未満をご利用中のお客様におかれましては、弊社のライフサイクルポリシーに基づく通常保守サービス期間中に稼働環境、および、製品のバージョンアップをお勧めします。



 

お問い合わせ先

各種お問い合わせ]-[製品に関するお問い合わせ]から、お問い合わせください。


入力フォーム「お問い合わせ概要」に「(000015839)SVF/SPA:Oracle JDKのリリースモデル変更に伴うサポート方針について」と入力してください。
 

更新履歴

日付

概要

2018/10/22 公開
2018/12/03 以下の情報を更新しました。
・Ver.9.2 Service Pack8にて予定しているSVF製品に対し、対応予定時期を記載しました。
・SVF Connect for IXOSに対し、対応バージョン、対応予定時期を記載しました。
2019/1/31 以下の情報を更新しました。
・SVF(Java版)製品にてVer.9.2 Service Pack8の適用を前提としJava11に対応した旨を記載しました。
・SVF EA Option、SPA ETL Optionの対応方針を更新しました。
・SPA Ver.9.2、Ver.9.3の対応方針を更新しました。
・「2019年1月1日以降、Javaを同梱し新たにリリースする製品の扱いについて」から「SPA ETL Optionを除くSPA製品 Ver.10.1」を削除しました。
2019/09/03 以下の情報を更新しました。
・SVF Connect for IXOSの対応予定時期を変更しました。
・SVF StraForm製品の対応予定時期を記載しました。
2019/12/16 StraForm製品にてVer.1.7 Service Pack4の適用を前提としJava11に対応した旨に更新しました。
2020/01/31 ・SVF Connect for IXOS Ver.9.2にてOracle Java11、Oracle OpenJDK13に対応した旨を更新しました。
・SPA ETL Optionのバージョンを「10.0」から「未定」に変更しました。
2020/12/07 「Oracle JDK/OpenJDK 11以降に対応するSVF/SPA製品」のSVF EA Connect、SPA ETL Optionの対応時期を更新しました。
2021/03/10 ・Amazon Corretto 8の対応予定を追記しました。これに伴い以下を変更しました。
  •  「Oracle JDK/OpenJDK 11以降に対応するSVF/SPA製品」⇒「Amazon Corretto8、JDK 11以降に対応するSVF/SPA製品」
  • 「Oracle JDK/OpenJDK 11以降に対応しないSVF/SPA製品の扱いについて」⇒「Amazon Corretto8、JDK 11以降に対応しないSVF/SPA製品の扱いについて」
  • 「Amazon Corretto8、および、JDK 11以降に対応するSVF/SPA製品」にSVF Web Designer、SVFX-Designerを追加しました。
2021/05/10 ・SVF Web DesignerとSVFX-Designerを除くSVF Ver.10にてAmazon Corretto 8に対応した旨を更新しました。
・SVF Web DesignerとSVFX-Designerにて以下を変更しました。
Ver.10.1(2021年5月リリース予定)にてAmazon Corretto 8の対応を予定してます。

Amazon Corretto8対応は時期が決まりましたら本ページにてご案内いたします。
2021/05/18 SVF Ver.9.2 Service Pack9にてAmazon Corretto 8に対応した旨を更新しました。
2021/06/30 SVF Web DesignerとSVFX-DesignerにてAmazon Corretto 8に対応した旨を更新しました。