SVF StraForm製品の動作状況について

製品ブランド:

SVF

公開日時:

2014/08/29 10:00

更新日時:

2019/12/16 09:56

記事番号:

000007143

サポートされるOSやミドルウェア、Java、DBのバージョンはSVF関連製品のみならず、相互にサポートされている必要があります。
運用環境をご確認のうえ、各ベンダーのサポート状況をご確認ください。

各記号の説明

 

サポート対象

条件付き ・ 制限あり

×

サポート対象外


凡例に※が記載されている項目は該当する注釈をご確認ください。
※1  Oracle JavaVM に対応しています。
※2  SVFX-Designer Ver.9.0、Ver.9.1およびService Pack1以前のVer9.2には、StraFormファイルのインポート、エクスポートを行う「デザインコンバーター」機能はありません。
※3  SVF StraForm Print Optionを利用し、SVF for Web/Clientに連携(クライアント環境で印刷)する場合にはInternet Explorer 64ビット版はサポート対象外です。
※4  事前に.NET Framework 3.5をインストールしてください。
※5  JDBCドライバは、各DBに付属のものを使用してください。
     (JDBCドライバは、JDK7、JDK8、JDK11で正常に機能する必要があります)
         JDK8、JDK11の利用時に適用が前提となるStraFormのService Packは【JavaVM対応表】をご確認ください。
※6  Oracle9iR2/10gR1/10gR2/11gR1/11gR2/12cR1/12cR2に対応しています。
※7  Ver.1.7 Service Pack1以降が適用されていることが前提です。
※8  Ver.1.7 Service Pack2以降が適用されていることが前提です。
※9  Ver.1.7 Service Pack1以前は互換モードのみに対応しています。 Ver.1.7 Service Pack2以降から標準モードの対応を追加しました。
※10 バージョン 1909以下に対応してます。
※11 Ver.1.7 Service Pack3以降が適用されていることが前提です。
※12 Ver.1.7 Service Pack4以降が適用されていることが前提です。
※13 HotSpotのみ対応です。
※14 AdoptOpenJDKに対応しています。
※15 各プラットフォームにおいて、サポート対象となるSVF StraForm Volcのバージョン、OpenJDKのディストリビューションは以下の通りです。  
   Windows:SVF StraForm Volc Ver.1.7SP4以降が適用されていることが前提にOracle OpenJDK、AdoptOpenJDK (HotSpot)に対応してます。
   Red Hat Enterprise Linux:以下の条件をすべて満たしていることを前提にRed Hat OpenJDKに対応しています。
    - Red Hat Enterprise Linux 7.6以降を利用していること  
    - SVF StraForm Volc Ver.1.7SP4以降が適用されていること
※16 実行部で動作保証しているバージョンの様式ファイルが使用できます。
    - 様式ファイル(frm/xml/vrq/FDL)における実行部バージョン組合せについて



【サーバー製品】

Windows Server

製品名

バージョン

2008
(x86 32bit)

2008
(x64 64bit)

2008 R2
(x64 64bit)

2012
(x64 64bit)

2012 R2
(x64 64bit) 

2016
(x64 64bit) 
2019
(x64 64bit) 

SVF StraFormサーバー

1.7

※11

※12
SVF StraForm Volc API

1.7

※11

※12
SVF StraForm Volc WebサービスAPI

1.7

※11

※12

 

Red Hat Enterprise Linux

製品名

バージョン

7(x86-64)

SVF StraFormサーバー

1.7

※7

SVF StraForm Volc API

1.7

※7

SVF StraForm Volc WebサービスAPI

1.7

※7

 


【クライアント製品】 

 

Windows

製品名

バージョン

Windows Vista
(x86 32bit)

Windows Vista
(x64 64bit)

Windows 7
(x86 32bit)

Windows 7
(x64 64bit)

Windows 8
(x86 32bit)

Windows 8
(x64 64bit)

Windows8.1
(x86 32bit)

Windows8.1
(x64 64bit)

Windows10
(x86 32bit)
Windows10
(x64 64bit)
SVF StraForm Designer

1.7

○ ※8※10

※8※10

SVF StraForm Design Converter

1.7

※10

※10

SVF StraForm Volc
クライアント表示

1.7

※8※10

※8※10

SVF StraForm動作設定

1.7

※8※10

※8※10

SVF StraForm Data Transit
Option クライアント
1.7

※4

※4

※4

※4

※4※10

※4※10



【Java VM対応表】 

製品名
 
バージョン
 
 Oracle Java OpenJDK
7(1.7.x)  8(1.8.x)  11

32bit

64bit

32bit 64bit 64bit
SVF StraForm Designer

1.7

×

※7

×

※12※13※14

SVF StraFormサーバー

1.7

※7

※7

※12※13※14
SVF StraForm Volc API

1.7

※7

※7

※15
SVF StraForm Volc WebサービスAPI

1.7

※7

※7

※15


 

.NET Framework対応表】 

製品名

バージョン

3.5

4.5

4.6

4.7

4.8
SVF StraForm Volc WebサービスAPI

1.7

×

SVF StraForm Data Transit Option クライアント

1.7



【Webアプリケーションサーバー対応表】

製品名

バージョン

Apache Tomcat

6.x

7.x

9.X
SVF StraForm Volc API

1.7

※7

※12

SVF StraForm Volc WebサービスAPI

1.7

※7

※12

 

【Webブラウザー対応表】

製品名

バージョン

Internet Explorer ※3

7

8 ※9

9 ※9

10 ※9

11 ※9

SVF StraForm Designer

1.7

SVF StraForm Volc
クライアント表示

1.7

SVF StraForm動作設定

1.7

 

 


【SVF関連製品との対応表】 

 

 

製品名

バージョン

SVFX-Designer

8.0

8.1

8.2

9.0

9.1 9.2 10
SVF StraForm Design
Converter 

1.7

※2

※2

※2

SVF StraForm Print
Option
1.7

※12

 

品名

バージョン

Universal Connect/X

SVF Java実行部

SVF for Web/Client

9.2

10

9.2

10

9.2

10
SVF StraForm Print Option

1.7

※16

※12 ※16

※16

※12 ※16

※16

※12 ※16



SVF StraForm Designerとの対応表】 

製品名

バージョン

SVF StraForm Designer

1.7

SVF StraFormサーバー

1.5

1.7

SVF StraForm Volc API

1.0

1.7

SVF StraForm Volc WebサービスAPI

1.0

1.7

SVF StraForm Design Converter

1.7

 

【データベース対応表】 ※5

SVF StraForm オプション(
SVF StraForm DB Browse Option / SVF StraForm Data Transit Option) を使用する際の対応データベース情報です。

製品名

バージョン

SQLServer

Oracle ※6

Dr.Sum(旧:Dr.Sum EA)

2005

2008

2008R2

2012

2012SP1

2016

2017

2019

9i

10g

11g

12c

18c

3.0SP3

4.0SP1

4.1

4.2

5.0

5.1

SVF StraFormサーバー

1.7

※11

※11

※12

※7

※12

 ○

 ○

※7

※8

※11

※12
SVF StraForm Volc API

1.7

※11

※11

※12

※7

※12

 ○

 ○

※7

※8

※11

※12
SVF StraForm Volc WebサービスAPI

1.7

※11

※11

※12

※7

※12

 ○

 ○

※7

※8

※11

※12

 


 

変更履歴

2014/8/29

FAQに公開しました。 

2014/9/2

誤植のため、※6 を削除しました。

2014/9/4

※6を追加しました。

2014/9/19

SVF StraForm Designer Ver.1.7との対応表を追加しました。
2015/8/10 ※7を追加しました。
※2の内容を変更、※5の内容を更新しました。
Red Hat Enterprise Linux、Java8、Oracle12c、Dr.Sum EA 4.1の対応状況を追加しました。
WAS対応表を追加しました。
SVF関連製品との対応表にSVFX-Designer Ver.9.0、Ver.9.1、Ver.9.2を追加しました。
2016/9/26 ※4の注釈を変更しました。
 ※4 実行部で動作保証しているバージョンの様式ファイルが使用できます。
   - 様式ファイル(frm/xml/vrq)における実行部バージョン組合せについて
 →
 ※4 事前に.NET Framework 3.5をインストールしてください。
※8、※9を追加しました。
Windows10を追加しました。
「SVF関連製品との対応表」に対して、「SVF StraForm Print Option」を追加しました。
Dr.Sum EA 4.2を追加しました。
2017/2/9 SVF StraForm Data Transit Option クライアント Ver.1.7に対し、Windows10の対応を追加しました。
2018/02/28 ※10、※11を追加しました。
以下を追加しました。
 - Microsoft SQL Server 2016、Microsoft SQL Server 2017、
 - Microsoft .NET Framework 4.6、Microsoft .NET Framework 4.7、
 - Dr.Sum Ver. 5.0 を追加しました。
2019/12/16 ・※12、※13、※14、※15、※16を追加しました。
※5の注釈を以下に変更しました。
修正前:※5  JDBCドライバは、各DBに付属のものを使用してください。  
         (JDBCドライバは、JDK7、JDK8で正常に機能する必要があります)
修正後:※5  JDBCドライバは、各DBに付属のものを使用してください。  
          (JDBCドライバは、JDK7、JDK8、JDK11で正常に機能する必要があります)  
         JDK8、JDK11の利用時に適用が前提となるStraFormのService Packは【JavaVM対応表】をご確認ください。
・Windows10のWindows10の November 2019 Update(1909)に対応しました。
以下を追加しました。
 - Windows Server 2019
 - OpenJDK11
 - .NET Framework 4.8
 - Apache Tomcat 9
 - SVF製品 Ver.10
 -SQL Server 2019、Oracle 18c、Dr.Sum 5.1

※本ページは予告なく変更することがあります。